Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 05:00 GMT
Scheduled
We'll be working on some of our systems from 5am to 6am and from 11pm to midnight on Tuesday 25 November.
Payments into and out of your account might be delayed. The app may take a little bit longer to load or complete journeys. If this happens please wait a minute and try again. Your card will work as normal in store.
Posted Nov 24, 2025 - 04:46 GMT
This scheduled maintenance affected: Paying money in, Sending money out, and Using Third Party Providers.