We've started opening accounts again
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted May 18, 2022 - 18:01 BST
Update
We are continuing to monitor for any further issues.
Posted May 18, 2022 - 14:39 BST
Monitoring
We've been working on our systems and we can now start to let people join us.

We're letting through a number of people at a time, so we appreciate your patience if you're not able to onboard right now.

We're looking forward to having you with us.
Posted May 18, 2022 - 14:37 BST
Identified
Because of a technical issue, you can't open a Chase account right now.

If you've recently tried to join us, it might take a while to receive your one-time passcode and verification email from us.

If you already bank with Chase, your usual notifications and messages from us might take a while to come through.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted May 17, 2022 - 23:00 BST
This incident affected: Joining us.