Rewards aren't showing properly right now
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted May 16, 2022 - 17:27 BST
Investigating
We have a problem with one of our systems at the moment.

It means that your Rewards balance won't show properly at the moment.

Your Rewards are still being earned in the background, we just can't show you how much you have right now.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted May 16, 2022 - 09:46 BST
This incident affected: Rewards.