We are working on our systems
Incident Report for Chase UK
Resolved
The issues that have affected our systems over the last couple of hours are now fixed.

Our Support team will be in touch with you if you need help to put things right.


We thank you for your patience and support.
Posted May 16, 2022 - 18:18 BST
Investigating
We have a problem with some of our systems at the moment.

You might not be able to see your pending transactions just now, and your balances might not be correct as a result.

You also might not be able to manage your card in your app or re-set your PIN.

You also might not be able to access your Rewards, or see your Rewards balance.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted May 16, 2022 - 17:30 BST
This incident affected: Paying money in, Sending money out, Moving money between accounts, and Rewards.