Payments are delayed at the moment
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted May 18, 2022 - 19:29 BST
Identified
We have a problem with some of our systems at the moment.



It means that payments and transfers are taking longer than normal.

Payments in are taking longer to reach your account and moving money between accounts is taking longer than usual. Payments out are also taking longer to get to their destination.

Transferring your rewards is also taking longer than normal.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted May 18, 2022 - 18:23 BST
This incident affected: Paying money in, Sending money out, Moving money between accounts, and Rewards.