Seeing a duplicate transaction?
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted May 27, 2022 - 23:02 BST
Update
We are continuing to investigate this issue.
Posted May 27, 2022 - 14:42 BST
Investigating
Usually when you pay with your card, the merchant asks us to authorise the amount. When this happens, the transaction shows up on your Activity list. The transaction shows as 'Pending' in the transaction details and we deduct the money from your balance in the app.

Sometimes, we'll get a second transaction come through. This second transaction is reversed within a few seconds so it disappears from your app. At the moment, that second transaction is taking longer to disappear, so the money looks like it has been taken from your account twice.

This second transaction should disappear from your app and your balance should be updated within 2 working days. If this doesn't happen, or this causes you problems, please contact us. We know this can be difficult and we're working to speed this back up.
Posted May 27, 2022 - 10:58 BST
This incident affected: Using your card.