Talking to us today
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Jan 30, 2023 - 23:27 GMT
Update
We are continuing to investigate this issue.
Posted Jan 30, 2023 - 22:16 GMT
Investigating
We have a problem with some of our systems at the moment.

It means that when you contact us at the moment, we won't be able to help you with specific questions about your account. We will be able to help you with general questions about Chase. Some of our team are also not able to respond to messages, so you might wait longer for a response.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Jan 30, 2023 - 22:16 GMT
This incident affected: Contacting us.