Talking to us today

Incident Report for Chase UK

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 18:44 GMT

Identified

We have a problem with one of our systems at the moment.

It means you can't call us through the app or on our usual number. We can still message with you, so please get in touch with us that way if you need to.

If you urgently need to speak to us or don't have your app to hand, please call us on +44 203 493 0829 instead. We won't charge you for calling, but you may be charged by your phone provider or if you're abroad.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Mar 18, 2025 - 11:30 GMT

Investigating

We have a problem with one of our systems at the moment.
It means that we can't speak to you on the phone at the moment. We can still message with you, so please get in touch with us that way if you need to.
We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Mar 18, 2025 - 08:40 GMT
This incident affected: Contacting us.