Planned work: Tuesday

Scheduled for Sep 22, 15:00 BST  -  Sep 23, 04:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 21, 2026 - 13:55 BST

Scheduled

We'll be working on some of our systems from 3pm to 4pm on Tuesday 22 September and from 3am to 4am on Wednesday 23 September.

Payments into and out of your account may be delayed. The app may take a little bit longer to load or complete journeys. If this happens please wait a minute and try again. Your card will work as normal in-store.
Posted Sep 21, 2026 - 13:45 BST
This scheduled maintenance affects: Paying money in, Sending money out, and Using Third Party Providers.