Issue with Rewards

Incident Report for Chase UK

Resolved

We're pleased to let you know your Rewards work now. We're sorry for the inconvenience and would like to thank you for your patience during this time.
Posted Jun 30, 2022 - 23:21 BST

Investigating

We're sorry, but a technical issue means your Rewards won't work right now. We're working on it and we'll let you know as soon as we've fixed the problem.
Posted Jun 30, 2022 - 19:58 BST
This incident affected: Rewards.