Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2024 - 07:00 GMT
Scheduled
We'll be working on our payment systems from 7am to 10am on Saturday 9th November.
You won't be able to add a new payee during this time. Any payments into or out of your account to existing payees will work as normal. Your card will also work as normal.
Posted Nov 09, 2024 - 00:18 GMT
This scheduled maintenance affected: Sending money out.