Delayed scheduled payments
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 00:02 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2022 - 09:34 BST
Investigating
We had a problem with some of our systems this morning.

It meant that standing orders and scheduled payments were not made at their usual time. They have now been made and there should be no impact to you.
Posted Jul 29, 2022 - 09:33 BST
This incident affected: Making regular payments.