Longer queues
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 04:23 BST
Investigating
You might have to wait longer to speak to us. If you can, check FAQS or try again later.
Posted Apr 24, 2024 - 21:41 BST
This incident affected: Contacting us.