Mobile data – network issues
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 09:53 BST
Identified
Just so you know, we're aware that some customers are experiencing issues with their mobile data network – meaning their apps aren't working as they should.

If this happens to you when you use the Chase app, please try switching to WiFi.

If you can't access WiFi, please get in touch.
Posted Jul 26, 2022 - 19:05 BST