Getting help today

Incident Report for Chase UK

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 09:19 BST

Investigating

We have a problem with some of our systems at the moment.

It means that it might take us longer to help you with some complex issues today. If this happens, we'll work on your case as soon as possible. We may have to ask you to call us back later.

We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Jul 17, 2025 - 08:59 BST
This incident affected: Contacting us.