Payments are slow right now
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Aug 01, 2022 - 07:10 BST
Investigating
We have a problem with some of our systems at the moment.

It means that money is taking longer to get to other people. We're also seeing that some customers are seeing a delay in payments showing up in their transaction payments.

The payment will still be processed as normal. It's just taking a little bit longer.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Aug 01, 2022 - 06:24 BST
This incident affected: Paying money in, Sending money out, Making regular payments, and Moving money between accounts.