Payments are taking longer than expected to process
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Jul 31, 2022 - 00:06 BST
Update
We are continuing to investigate this issue.
Posted Jul 30, 2022 - 21:55 BST
Investigating
We're sorry, but a technical issue means payments are taking longer to process right now. They're being held but will be made. Your card works as normal. We're working on it and we'll let you know as soon as we've fixed the problem.
Posted Jul 30, 2022 - 21:55 BST
This incident affected: Paying money in, Sending money out, Making regular payments, and Moving money between accounts.