Text message about account balances
Incident Report for
Chase UK
Resolved
This incident has been resolved.
Posted
Nov
07
,
2024
-
21:22
GMT
Investigating
We have a problem with one of our systems at the moment.
It means that a text message went out from us earlier today about account balances. If you received this message in error, please ignore it.
We're sorry for any confusion this caused.
Posted
Nov
07
,
2024
-
17:36
GMT
×
Subscribe to Incident
Subscribe to updates for
Text message about account balances
via . You'll receive .