Trouble with documents
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 15:46 BST
Update
We are continuing to investigate this issue.
Posted Aug 02, 2022 - 15:45 BST
Update
We are continuing to investigate this issue.
Posted Aug 01, 2022 - 23:02 BST
Investigating
We have a problem with some of our systems at the moment.

It means that some customers are having trouble opening some of their documents. Not all customers are affected.

We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.
Posted Aug 01, 2022 - 22:27 BST