We're sorry

Incident Report for Chase UK

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:25 BST

Update

We're still investigating this issue with our Support team's systems at the moment. Our team still can't access any details about your account when you contact us. That means we can't answer specific questions about your account. Your data is not affected.
Posted Sep 16, 2026 - 11:48 BST

Update

We are continuing to investigate this issue.
Posted Sep 16, 2026 - 10:54 BST

Investigating

We can't help you with your account at the moment, only general questions.
Posted Sep 16, 2026 - 09:57 BST
This incident affected: Contacting us.