Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 27, 2024 - 01:00 GMT
Scheduled
We'll be working on our payment systems from 1am to 7am on Sunday 27 October.
You won't be able to make payments out of your account during this time. Any payments into your account will also be held in a queue until the work finishes. Your card will work as normal.
If you have any scheduled payments set up during this time, they will be made once the work is finished. You don't have to do anything – we'll take care of it.
Posted Oct 25, 2024 - 08:52 BST
This scheduled maintenance affected: Paying money in, Sending money out, and Using Third Party Providers.