Resetting your passcode
Incident Report for Chase UK
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 15:08 BST
Investigating
More customers than usual are trying to reset their passcode at the moment. This means it might take longer than normal to have your ID documents and selfie checked. We've got all hands on deck to get through the queue as fast as possible. You don't need to try to reset more than once.

To make this process faster for our customers, new customers won't be able to join us at the moment. Please come back and try again later.
Posted Oct 06, 2022 - 09:58 BST
This incident affected: Joining us and Logging in.