We've fixed the issue affecting users with new iPhone 14 Pro and Pro Max. If you have had trouble logging in or joining us with one of these phones, please update the app. You'll need version 1.16.2 to continue.
Posted Sep 20, 2022 - 19:33 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2022 - 20:19 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 16, 2022 - 15:39 BST
Investigating
We have a problem with logging in on new iPhone 14 Pro and Pro Max devices at the moment.
It means that you can't easily set up the Chase app on your new phone when you use a UK driving licence to log in.
To set up the Chase app on your iPhone 14 Pro and Pro Max, please use your passport.
If you don't have a passport, please choose 'UK driving licence' from the ID list and then don't put the driving licence in the frame. After a minute or so, you will have the option to take the picture manually. Then please make sure the ID is far enough away from the camera to be in focus before taking the picture. You'll then be offered the option to say 'I'm having trouble/. Please choose this and then 'yes please'.
We know you count on your bank for the important things in life. We are working as fast as we can to fix the problem and will update you as soon as we know more. We're sorry for any problems this causes you.